Ярослав Галкин/ Ноябрь 27, 2017/ ЕГЭ-08/ 0 комментариев

Определите, какое число будет напечатано в результате выполнения программы, записанной ниже на разных языках программирования.

Бейсик
Python
DIM N, S AS INTEGER
N = 1
S = 0
WHILE N <= 150
 S = S + 40
 N = N * 5
WEND
PRINT S
n = 1
s = 0
while n <= 150:
s = s + 40
n = n * 5
print(s)
Алгоритмический язык
Паскаль
алг
нач
 цел n, s
 n := 1
 s := 0
 нц пока n <= 150
s := s + 40
n := n * 5
 кц
 вывод s
кон
var n, s: integer;
begin
 n := 1;
 s := 0;
 while n <= 150 do
 begin
s := s + 40;
   n := n * 5
 end;
 write(s)
end.
Си
#include<stdio.h>
int main()
{
 int n, s;
 n = 1;
 s = 0;
 while (n <= 150)
 {
s = s + 40;
n = n * 5;
 }
 printf(“%d”, s);
 return 0;
}
Ответ:
160

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

Оставить комментарий

avatar

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.

  Подписаться  
Уведомление о