Ярослав Галкин/ Ноябрь 28, 2017/ ЕГЭ-20/ 0 комментариев

Ниже на пяти языках программирования записан алгоритм. Получив на вход натуральное число x, этот алгоритм печатает число R. Укажите такое число x, при вводе которого алгоритм печатает двузначное число, сумма цифр которого равна 13. Если таких чисел x несколько, укажите наименьшее из них.


Бейсик
Python
DIM X,D,R  AS LONG
INPUT X
R = 0
WHILE X>0
D = X MOD 10
R = 10*R + D
X = X 10
WEND
PRINT R
x = int(input())
R = 0
while x>0:
d = x % 10
R = 10*R + d
x = x // 10
print(R)
Алгоритмический язык
Паскаль
алг
нач
 цел x, d, R
 ввод x
 R := 0
 нц пока x>0
   d := mod(x, 10)
R := 10*R + d
x := div(x, 10)
 кц
 вывод R
кон
var
x,d,R: longint;
begin
 readln(x);
 R := 0;
 while x>0 do
  begin
d := x mod 10;
R := 10*R + d;
x := x div 10
  end;
 writeln(R)
end.
Си
#include <stdio.h>
int main()
{
 long x,d,R;
 scanf(“%ld”, &x);
 R = 0;
 while (x>0)
  {
d = x % 10;
R = 10*R + d;
x = x / 10;
  }
 printf(“%ld”, R);
 return 0;
}

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

Оставить комментарий

avatar

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.

  Подписаться  
Уведомление о