Ярослав Галкин/ 10 апреля, 2018/ Есть решение, ОГЭ-20.1/ 0 комментариев

Описание СКИ Робот

Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может.

У Робота есть девять команд. Четыре команды – это команды-приказы:

вверх вниз влево вправо

 

При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑, вниз ↓, влево ←, вправо →. Если Робот получит команду передвижения через стену, то он разрушится.

Ещё четыре команды – это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырёх возможных направлений:

сверху свободно снизу свободно слева свободно справа свободно

 

Эти команды можно использовать вместе с условием «eсли», имеющим

следующий вид:

если условие то

последовательность команд

все

Здесь условие – одна из команд проверки условия.

Последовательность команд – это одна или несколько любых команд -приказов.

Например, для передвижения на одну клетку вправо, если справа нет стенки, можно использовать такой алгоритм:

если справа свободно то

вправо

все

В одном условии можно использовать несколько команд проверки условий,

применяя логические связки иилине, например:

если (справа свободно) и (не снизу свободно) то

вправо

все

Для повторения последовательности команд можно использовать цикл

«пока», имеющий следующий вид:

нц пока условие

последовательность команд

кц

 

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

нц пока справа свободно

вправо

кц

Также у Робота есть команда закрасить, при которой закрашивается клетка, в которой Робот находится в настоящий момент.

На бесконечном поле имеется стена, состоящая из 5 последовательных отрезков, расположенных змейкой: вправо, вниз, влево, вниз, вправо, все отрезки неизвестной длины. Робот находится в клетке, расположенной снизу от левого края первой горизонтальной стены.

На рисунке указан один из возможных способов расположения стен

и Робота (Робот обозначен буквой «Р») .

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные ниже первого и левее второго отрезков стены и левее четвертого и ниже пятого отрезков стены и угловой клетки. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок)

Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для произвольного размера поля и любого допустимого расположения стен внутри прямоугольного поля. При исполнении алгоритма Робот не должен разрушиться.

Алгоритм может быть выполнен в среде формального исполнителя или  записан в текстовом редакторе.

Название файла и каталог для сохранения Вам сообщат организаторы экзамена.

Посмотреть решение
использовать Робот
алг
нач
 нц пока справа свободно
   закрасить
   вправо
 кц
 нц пока снизу свободно
   закрасить
   вниз
 кц
 закрасить | закрашивает первую критичную точку
 нц пока снизу стена
   влево
 кц
 вниз | переход к началу повтора
 нц пока справа стена
   закрасить
   вниз
 кц 
 закрасить | закрашивает вторую критичную точку
 вправо | переход к началу повтора
 нц пока сверху стена
   закрасить 
   вправо 
 кц
кон

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

0 0 Оценка
Article Rating

Автор публикации

не в сети 1 час

Ярослав Галкин

2
Эксперт ЕГЭ, учитель высшей категории.
Комментарии: 16Публикации: 258Регистрация: 01-01-2019
Подписаться
Уведомление о
guest

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.

0 Комментарий
Inline Feedbacks
Показать все комментарии