Лайфхак: Получение сводных данных из различных реестров и баз

В работе заместителя директора и методиста школы в любой момент может возникнуть необходимость посмотреть на сводную информацию по данным всех учащихся, которая может быть выгружена из какой-либо базы данных. Естественно мы рассматриваем случаи, когда такой сводный отчет отсутствует в самой системе.
Практически любая Excel-аналитика образовательной организации сводится к использованию одной единственной формулы – СЧЁТЕСЛИ.

Допустим, мы имеем информацию о количестве кружков и секций который посещает каждый ученик в школе и мы хотим узнать, сколько учеников посещает 1, 2, 3 и т.д. кружков.
Выполнить эту операцию можно за 5 минут используя данные хоть по 100, хоть по 3000 учащихся:

  1. Формируем шаблон будущей сводки в пустой части таблицы. Наш шаблон занимает диапазон D1:I3 и мы узнаем сводку по включению учащихся от одной до пяти групп (E1:I1).
  2. Определяемся с диапазоном интересующих нас данных. Для бесплатных кружков в нашем случае взят диапазон B3:B12, а для платных C3:C12.
  3. В ячейку E2 вводим формулу:
    =СЧЁТЕСЛИ($B$3:$B$12;E1) – считать ячейку в диапазоне если будет совпадение с единицей (ячейкой E1_, $ – фиксирует значение адреса по строкам и столбцам.
     В ячейку E3 вводим формулу:
    =СЧЁТЕСЛИ($C$3:$C$12;E1)
  4. Копируем или протягиваем ячейки E2 и E3 в ячейки диапазонов F2:I2 и F3:I3 соответственно. Не зафиксированная часть формулы сама будет менять адрес ссылки на ячейку ровно на столько строк и столбцов, на сколько вы скопируете саму формулу.
Ваша сводка готова! Как я уже сказал, эту формулу можно использовать для любых расчетов, важно только знать: какие у вас есть исходные данные, и что вы хотите получить.

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

Оставьте комментарий

Войти с помощью: 

Ваш e-mail не будет опубликован.

 необходимо принять правила конфиденциальности

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.

Сообщить об опечатке

Текст, который будет отправлен нашим редакторам: